Email us

Email us
Business I.T support Brighton from LJE Ltd.

Thursday 4 November 2010

apple Mac create usb boot disk from .iso

Download the .iso image or copy to your Mac

open 'Terminal' from applications/utilities

in terminal navigate to the downloaded iso

ie
cd /Downloads

then create .img from .iso

'hdiutil convert -format UDRW -o bootcdrom-image.img boot-cdrom-iso.iso'

MacOSX tends to add .dmg to end of name

next insert usb flash drive and list all devices to determine the usb flash device name

diskutil list
/dev/disk0
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *160.0 GB disk0
1: EFI 209.7 MB disk0s1
2: Apple_HFS data 80.0 GB disk0s2
3: Apple_HFS Untitled 2 79.5 GB disk0s3
/dev/disk1
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *1.0 GB disk1
1: DOS_FAT_32 MULTIBOOT 1.0 GB disk1s1
/dev/disk2
#: TYPE NAME SIZE IDENTIFIER
0: bootcdrom-image *729.7 MB disk2

in our case above usb disk is /dev/disk1 (1GB disk)

unmount the usb drive
i.e
diskutil unmountDisk /dev/disk1
Unmount of all volumes on disk1 was successful

create usb image of .dmg file created earlier
sudo dd if=./bootcdrom-image.img.dmg of=/dev/rdisk1 ( note /dev/rdisk1 and not /dev/disk1 as shown in diskutil list)

wait for some time for copy to complete.
To check progess you could open a new terminal window and type 'iostat 5'

you wil see stats update for disk 0 and disk 1 ( in our case) hard drive to usb drive whilst copy if going on

disk0 disk1 disk2 cpu load average
KB/t tps MB/s KB/t tps MB/s KB/t tps MB/s us sy id 1m 5m 15m
28.01 61 1.67 0.50 79 0.04 1.29 0 0.00 5 6 88 0.91 0.53 0.34
76.66 22 1.63 0.50 1970 0.96 0.00 0 0.00 2 40 59 0.92 0.54 0.35
108.34 9 0.99 0.50 1996 0.97 0.00 0 0.00 2 37 61 0.93 0.55 0.35
350.32 4 1.30 0.50 1147 0.56 0.00 0 0.00 3 22 75 0.85 0.54 0.35
23.90 40 0.93 0.50 1598 0.78 0.00 0 0.00 0 34 66 0.94 0.56 0.36
227.26 8 1.69 0.50 1989 0.97 0.00 0 0.00 2 37 61 0.95 0.57 0.36
55.97 41 2.23 0.50 1997 0.98 0.00 0 0.00 2 37 62 0.95 0.58 0.36
37.38 47 1.71 0.50 2007 0.98 0.00 0 0.00 2 37 61 0.96 0.58 0.37
45.29 42 1.84 0.50 1986 0.97 0.00 0 0.00 3 37 60 0.96 0.59 0.37
35.61 57 1.97 0.50 1993 0.97 0.00 0 0.00 2 37 61 0.88 0.58 0.37

after the dd has complete you can close down the mac and remote the usb flash drive

you'll see something like.....

1425188+0 records in
1425188+0 records out
729696256 bytes transferred in 742.131480 secs (983244 bytes/sec)

you can close down the mac and remote the usb flash drive
then you can plug in usbdrive to mac or pc to boot from